Добрый день. Я занимаюсь web-разработкой и почти всем, что с этим связано.

Какие версии PHP используют для MODX Revolution

Не все знают, но пакетный менеджер MODX (тот самый, с помощью которого устанавливаются дополнения) отправляет дополнительную информацию провайдеру пакетов. Это нужно для того, чтобы определить, поддерживается ли дополнение текущей системой (зависит от СУБД, версии PHP и пр.). Также данная информация используется при проверке лицензии, например, неофициальными репозиториями.

Начиная с MODX Revolution 2.4 эта информация включает также версию PHP. И вот такая ситуация в modmore на декабрь 2016.

MODX Revolution и версии PHP
MODX Revolution и версии PHP

Здесь представлено 3565 уникальных установок MODX версии от 2.4.0, использующих дополнения от modmore.

Чем полезна данная статистика? Как минимум тем, что разработчикам проще понять, стоит ли использовать новые возможности языка или поддерживать устаревшие. 

Комментарии